Ok after scouring the internet for this shit I solved it myself. This is tested on Dell Inspiron 2200 your situation may be different.

first:
Code:
[email protected]#: ifconfig wlan0 up
SIOCSIFFLAGS: Unknown error 132
lets find out why there's an error
Code:
[email protected]#: dmesg | tail -20
and find this
Code:
b43-phy0: Radio hardware status changed to DISABLED
Ok, the laptop has switched off the rf signal for the card, let's confirm this by entering this:
Code:
[email protected]#: rfkill list
1: phy1: Wireless LAN
           Soft blocked: no
           Hard blocked: yes
As far I i know, unless anyone has a better fix for this where the rf signal remains on, we just have to switch the signal back on. On the Dell Inspiron 2200 the switch to enable the wlan card is Fn+F2. The toggle is a daemon running on the Inspiron's BIOS so it will work regardless of OS. So toggle on the card and check it using the previous command: rfkill list. You should now see that the block has been removed.

you may be able to enter the following command to enable the card if the previous does not work for you:
Code:
rfkill unblock all


rtl8187 Driver

If you have the rtl8187 driver and see "wireless radio switch turned off" on your dmseg report, here's the fix from backtrack for you:
Code:
[email protected]:~# rmmod rtl8187
[email protected]:~# rfkill block all
[email protected]:~# rfkill unblock all
[email protected]:~# modprobe rtl8187
[email protected]:~# rfkill unblock all
[email protected]:~# ifconfig wlan0 up






If you are still running into problems and your rfkill list is showing no blocks, reboot the computer with the wlan0 card in its enabled state and it shouold work after that.